Last Updated:

Plugin is too old, please update Error in Android Studio

Today we will talk about such a common error when working in Android Studio as Android Studio – Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE environment variable to xxx.

Recently, I myself encountered this problem and did not find a solution to this problem on the Internet. All the proposed methods were either outdated or simply not working. The decision came after I just read the essence of the problem myself. Android Studio clearly indicates the essence of the error: the plugin is outdated, please update it - this is in short. 

What is this error?

The error says Plugin is too old, please update to a more recent version and this means that the build system of the Gradle project, which is used in the Android Studio development environment, is outdated and can no longer build your application.

How do I solve the problem?

Go to the Gradle Scripts section in the project structure and open the build.gradle file:

update Error in Android Studio

You should open a file with content similar to the following:

We are interested in a block with dependencies. Android Studio swears at it, so we need to replace it with another version. You can find it at https://bintray.com/android/android-tools/com.android.tools.build.gradle/view.

Do not use the latest version, as the developer tools and your Android Studio do not know how to work with it:

update Error in Android Studio

We'll take a version and paste it in our dependencies block — it's newer than ours, but not the newest:2.0.0

Now synchronize the project using the "Sync Project with Gradle Files" button on the toolbar and see how the new version of Gradle is loaded and the project is built:

update Error in Android Studio

Все, теперь проблема Android Studio — Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE environment variable to для этого проекта решена.

Note that I wrote for this project. To prevent this error from appearing again in Android Studio, you need to understand where it comes from.

Why do I get this error?

The thing is that the developer tools, Android SDK and Android Studio are updated very often and you probably have seen the offer to update some tools more than once when you start the development environment:

update Error in Android Studio

Many are updated as soon as such an offer arrives, but in my case I have ignored this offer for a long time. This is what caused the Plugin is too old, please update to a more recent version. That is, ideally, you should always update as soon as such an offer comes, but if you do not want to do this, then use the method suggested in this article.

Stay tuned and subscribe to new articles.